I had this issue after a recent format and install of my server software. I just noticed it now though, although if you pay attention to the number of time I post, well, it is self-explanatory.

I solved it after I read an article that spoke of the same issue, but focussed more on the ftp-user sh-tick.

The gist of the article has to deal with using ftp-user alongside httpd. This may raise some security issues like one commenter stated, but it is easier just to make your files (chown www-data:www-data) owned by the web server, you can do this only to the directory that holds your web documents and all is well. Your auto-updater built-in to wordpress is working again!